MPEG Streamclip usage

  • export video as image sequence
  • convert image sequence into video
  • convert video formats

Basic Video Editing Skills for Youtube Video

  • Single Video Editing Steps
    1. Find the video you like to edit on Youtube
    2. copy the URL link in Browser, and go to http://keepvid.com/ site to paste the link and click download
      1. the KeepVid site will provide links for download your Youtube video's Video File(mp4) and audio file (mp3)
      2. click on the best quality video file (video only) link, a window pops up, then copy the text (it is the file name)
      3. then right click the video file (video only) link, and choose Save as, and save to your footage folder.
      4. then same above method to download the audio M4A file (audio only), and save to your footage folder
      5. combine the video and audio together with this supporting software. KeepVid Video Joiner http://keepvid.com/programs
      6. run VidJoin.exe software from KeepVid, and load the MP4 video file and M4A audio file in, and click Join. Then save the result video with sound into footage folder
    3. Edit your video in MPEG_Streamclip software, available for both Windows and Mac. download the lastest version: http://www.squared5.com/
      1. click File menu > Open, to load your mp4 video.
      2. play back your video in youtube and take note down the start time and end time of the part you want to trim out (meaning taking out that part as separate file)
      3. in the MPEG_Streamclip, click Edit menu > go to time.. , then enter the start time as Hour:Min:Sec format, then click Edit menu > Select In to set the In point (means trim start point)
      4. then, click Edit menu > go to time.. , then enter the end time as Hour:Min:Sec format, then click Edit menu > Select Out to set the Out point (means trim end point)
      5. after set the In-Out point, then click Edit menu > Trim.
      6. Trim editing down, then click File > Save as. name as same name with addition info like In_Time_Out_Time for your reference.
    4. Done, use your video player to check that trimmed video
  • Multiple Video Combine Editing
    1. in MPEG_Streamclip, File menu > Open files, choose all the video clip that you want to combine together in selection order.
    2. then in File menu > Export to MPEG-4, in pop-up option panel, choose H.264 from top Compression menu, and quality 80% enough. Sound, choose MPEG-4 AAC, 256kbps enough. Frame size as original, sample video case is 1920×1080 (unscaled). rest should be fine with default. click Make MP4 button at bottom to complete.
  • Additional Single Video Editing Skills
    • Resize video
      1. click File menu > Open file to load the video to be resized.
      2. then File menu > Export to MPEG-4, under Frame size, choose the Frame size you want to resize to or under Others to enter your own size, (note, make sure the width by height ratio is same, otherwise, black color will fill the border area )
    • Crop Video
      1. under File menu > Export to MPEG-4, in crop area, enter the how many border pixel to crop from 4 sides.
    • simple Color Correct Video
      1. under File menu > Export to MPEG-4, click “Adjustments..” button at the bottom, and choose the Brightness/Contrast/Saturation then Ok and Make MP4
    • adjust video sound volumn
      1. under File menu > Export to MPEG-4, click “Adjustments..” button at the bottom, and choose the Volumn adjustment to lower or boost sound, then Ok and Make MP4
    • mute/remove video sound
      1. under Edit menu > Delete audio track, and File menu, Save as … to save a non-sound video file.
    • add background sound to video ???
      1. File menu > open files, and choose your video file and your background sound/music file (like mp3, wav, m4a) together.
      2. under File menu > Export to MPEG-4 to save it.
    • save a still frame picture from video
      1. use your video player to find the time of your prefered still frame
      2. File menu > open files to load your video
      3. then File menu > Export Frame, choose Frame size - unscaled, Format as JPEG or PNG, quality to right most best quality, click OK to save.
    • save audio only out from video
      1. File menu > open files to load your video
      2. File menu > Export Audio, then choose format as MP3, stereo, sample rate auto, bit rate 256kbps is fine enough. then OK to save it.