Free vs Paid version of Resolve 12

  • Paid advantage are mainly useful for big studios with big scale management of hardware and manpower
    • Noise reduction and Motion Blur effect
    • Stereoscopic 3D video production
    • Remote management system
    • Video control surface hardware support
    • 5k, 6k, 8k video production
    • Multi-GPU acceleration support (resolve 12 only can use 1 GPU, and 2 on MacPro)

DaVinci Resolve 12 Media Note

input File Format resolution
video format .mov, .mts (AVCHD), mp4 4k, FHD, HD, SD
image format .DPX, Cineon, tif, OpenEXR (layers), png, psd, jpg
audio file .wav, .aiff
Output File Format resolution
video format .mov
image format .tif, .exr
audio file .wav, .aiff

DaVinci Resolve 12 Edit Note

track normal trim edit A
track ripple trim edit T
track razor cut edit B
track slip edit (slide in-out point in source) T
insert clip from source In-Out F9
delete clip from track backspace
ripple delete from track shift + backspace
Snapping option switch N
add a mark M

Intro to Interface

  • Most Important Edit Tool icon
    • cursor: selection and basic editing tool
    • filmstrip with slider: ripple editing tool
    • razor: split video block
  • Footage insert tool (after you set the In and Out point in Source Video Panel)
    • Insert: it will insert the footage at the Timeline playback header position, and push the rest of video forward
    • Override: it will insert the footage at the Timeline playback header position, and cover up rest of video up to the in-out length of source video
    • Replace: it will replace the selected video block with the source, if the length of source video is not long enough, original selected video block will fill the empty portion
  • Snap and link
    • Snap option: it will help move each video block to the end or header tip of other video blocks, like a magnet sticks
    • link option: it will keep video track and audio track together when moving them as a whole block
  • show Audio track waveforms - steps:
    1. click on the icon on the very right of Timeline panel next to “timeline zoom slider”
    2. then, it shows “Timeline view option” pop-up panel,
    3. check the option “Show Audio Waveforms” and drag to max the “Track Height Audio”

Using Matte footage

Keying Green screen

Audio editing essentials

subtitle workflow

  • solution 0: manually create text blocks along timeline and fit for video
  • solution 1: subtitle text software > subtitle text to video conversion > import subtitle video into resolve
  • solution 2: data burn-in tab in resolve color page > load certain format file
  • solution 3: use other video editor has better support with subtitle, then use other video editor to create subtitle, and then export EDL common non-linear editor exchange file format, import into resolve to create subtitle text timeline
  • solution 4 (srt subtitle import workflow):
    1. upload video to youtube and let youtube generate the subtitle, download youtube subtitle with this online app: http://www.lilsubs.com/
    2. once you get the srt file, convert it from srt to finalcut xml file
      1. convert method 1: use online app to convert: https://resolver.tools/subsimple/
      2. convert method 2: use subtitle edit free tool: https://github.com/SubtitleEdit/subtitleedit/releases, download the zip file and extract to a folder that you keep the software, launch subtitleedit.exe, and open the srt with it and File menu > Export as FinalCut XML Advanced, make sure frame rate same as your video setting
    3. (make sure your resolve project setting is correct with its frame rate as well)
    4. import the fcpxml file into resolve by File > Import Timeline > Import XML, then it create a new timeline with subtitle in the center, select all text clip inside, and use inspector to change Y position down a bit and format with text option there.
    5. Note: the new timeline will start with timecode of first subtitle clip, so maybe not frame 0 at default
      1. the solution 1: you manual copy all the text clips to your video timeline with playhead at that timecode
      2. the solution 2: create a dummy subtitle line at frame 0 in subtitle edit app, so it always fit right there
  • Save Text Preset into Power Bin by drag into Power Bin from timeline (feature since version 12.5)
    • View menu > Show Power Bin (a common preset bin)
https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=32367
https://mixinglight.com/portfolio/using-data-burn-text-layers-legible-client-notes/
https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=38813

Add alpha to Footage

ref: https://www.youtube.com/watch?v=1fkXde6bUOw

  1. masking in each node is only for each node's Grading
  2. to output the alpha to overall clip, you need add Right-Click menu > Add Alpha Output, then it will use masking information from Power Curve or Key to create alpha channel,
  3. then in timeline, this clip will behave like Photoshop layer with alpha channel.

Move Projects into Resolve from Other Non-linear editors like Premiere and FCP

Publish Format and Bitrate

Complete Training Tutorials

Problem and Bottle Neck

Optimized Media and Proxy

  • reference and explain: https://youtu.be/RukXAj8FEwU
  • Project setting: “General Options” : “Optimized Media” : choose a playback size and a codec with proxy option
  • check “use optimized media when available” in playback menu, and proxy mode to set the proxy resolution
  • when rendering, just make sure un-check “use optimized media when available”

Render Cache and Playback

    • resolve Caching flow:
      1. Source cache: cache before any color panel operation, good for dealing large RAW sequence footage, it can be used as on-the-fly proxy generation, and source cache is using timeline resolution, so 4k footage output 1080p only cache at 1080p; source cache is auto by-default
      2. Node cache: cache on per node level in color panel operation, good for speed up after a heavy effect on a node, auto by-default
      3. clip cache: last caching point, need manually check “Render cache clip output” in color panel view, since any pre change will break the cache result; Normally indicate Cache outdated in “Red text”.
      4. sequence cache: only with in Smart Mode of cache, it will cache any composite clip and clip with speed or opacity setting.
    • cache can be outdated if source is changed in each stage
    • cache can be re-render when there is 5 sec of inactivity
    • if cache take too much space, then Playback menu > Delete Render Cache > unused
  • Any i5 CPU with integrated graphic card and above can do 1 hour 1080p edit no problem, with SSD 250GB for footage, and 128GB extra SSD for cache file
  • while anything like 4k or longer hour video will require more disk space for cache file, so be prepared for 512GB SSD for cache file.
  • Temporary solution:
    • if run out disk, delete render cache > unused render cache; if still not enough, delete all render cache work with small area of timeline one at each time, or better to add a big SSD for cache file
    • if with cache file, you should be able to play back smoothly
    • also, a dedicated graphic card will render and playback faster, or get faster CPU

Resolve 12.5.1 onwards MOV file crash issue

  • because since 12.5.1 version, resolve remove the requirement for Apple quicktime player, and it starts using its own decode, which making it sometimes it crash when dealing with MOV file
  • luckily, the original 12.5.0 version still uses the old Apple quicktime to display MOV file, which has no issue.
  • you can get the resolve 12.5 version first until they fix the MOV issue in later version. (12.5.3 tested with same issue)
  • old version download can be found the news section: https://www.blackmagicdesign.com/support/family/davinci-resolve-and-fusion

Resolve 12.5 4K H.264 render fail on windows 7

  • Resolve 12.5 on windows, UHD H.264 requires windows 10
  • alternative solution: QuickTime>MPEG4 Video>3840×2160 Ultra HD

Resolve 14,15 initialize the discrete GPU

  • Problem: after install, resolve pop “Davinchi Resolve is unable to run as the application was not able to initialize the discrete GPU. Please ensure that DaVinci Resolve is configured to run in performance mode in your graphics card settings utility.”
  • Solution:
    • install the new driver for your discrete GPU, or just install latest driver for your graphic card
    • if you have switchable graphic laptop, in graphic setting, choose “performance” for that resolve application in graphic utility.