Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
appwiki:mpegstreamclip [2016/01/17 06:37]
ying [Basic Video Editing Skills for Youtube Video]
appwiki:mpegstreamclip [2016/10/20 01:17] (current)
Line 17: Line 17:
     * KeepVid Video Joiner (a Youtube video audio combiner, windows): http://​keepvid.com/​programs     * KeepVid Video Joiner (a Youtube video audio combiner, windows): http://​keepvid.com/​programs
     * MPEG_Streamclip (video trimmer and combiner, windows and mac): http://​www.squared5.com/​     * MPEG_Streamclip (video trimmer and combiner, windows and mac): http://​www.squared5.com/​
 +      * note: MPEG_Streamclip playback is bad, use your video player to check time portion
  
-  * Single Video Editing Steps+  ​* **Single Video Editing Steps**
     - Find the video you like to edit on Youtube ​     - Find the video you like to edit on Youtube ​
       * sample video 1: https://​www.youtube.com/​watch?​v=A9HV5O8Un6k       * sample video 1: https://​www.youtube.com/​watch?​v=A9HV5O8Un6k
Line 38: Line 39:
     - Done, use your video player to check that trimmed video     - Done, use your video player to check that trimmed video
  
-  * Multiple Video Combine Editing+  ​* **Multiple Video Combine Editing**
     - in MPEG_Streamclip,​ File menu > Open files, choose all the video clip that you want to combine together in selection order.     - in MPEG_Streamclip,​ File menu > Open files, choose all the video clip that you want to combine together in selection order.
     - then in File menu > Export to MPEG-4, in pop-up option panel, choose H.264 from top Compression menu, and quality 80% enough. Sound, choose MPEG-4 AAC, 256kbps enough. Frame size as original, sample video case is 1920x1080 (unscaled). rest should be fine with default. click Make MP4 button at bottom to complete.     - then in File menu > Export to MPEG-4, in pop-up option panel, choose H.264 from top Compression menu, and quality 80% enough. Sound, choose MPEG-4 AAC, 256kbps enough. Frame size as original, sample video case is 1920x1080 (unscaled). rest should be fine with default. click Make MP4 button at bottom to complete.
 +
 +  * Additional Single Video Editing Skills
 +    * **Resize video**
 +      - click File menu > Open file to load the video to be resized.
 +      - then File menu > Export to MPEG-4, under Frame size, choose the Frame size you want to resize to or under Others to enter your own size, (note, make sure the width by height ratio is same, otherwise, black color will fill the border area )
 +    * **Crop Video**
 +      - under File menu > Export to MPEG-4, in crop area, enter the how many border pixel to crop from 4 sides.
 +    * **simple Color Correct Video**
 +      - under File menu > Export to MPEG-4, click "​Adjustments.."​ button at the bottom, and choose the Brightness/​Contrast/​Saturation then Ok and Make MP4
 +    * **adjust video sound volumn**
 +      - under File menu > Export to MPEG-4, click "​Adjustments.."​ button at the bottom, and choose the Volumn adjustment to lower or boost sound, then Ok and Make MP4
 +    * **mute/​remove video sound**
 +      - under Edit menu > Delete audio track, and File menu, Save as ... to save a non-sound video file.
 +    * **add background sound to video ???**
 +      - sample music 1: https://​www.youtube.com/​watch?​v=FkyUW5hhsxc
 +      - File menu > open files, and choose your video file and your background sound/music file (like mp3, wav, m4a) together.
 +      - under File menu > Export to MPEG-4 to save it.
 +    * **save a still frame picture from video**
 +      - use your video player to find the time of your prefered still frame
 +      - File menu > open files to load your video
 +      - then File menu > Export Frame, choose Frame size - unscaled, Format as JPEG or PNG, quality to right most best quality, click OK to save.
 +    * **save audio only out from video**
 +      - File menu > open files to load your video
 +      - File menu > Export Audio, then choose format as MP3, stereo, sample rate auto, bit rate 256kbps is fine enough. then OK to save it.